Model Boat Mayhem - Forum

Technical, Techniques, Hints, and Tips => The "Black Arts!" ( Electrics & Electronics ) => Topic started by: me3 on April 27, 2016, 09:58:42 PM

Title: Action P96 Servo Morph Lag
Post by: me3 on April 27, 2016, 09:58:42 PM
Hi all,

I eventually got a P96 Servo Morph. Its all wired up and worked as expected. Only problem is there is a lag of about 2-3 seconds before the servo reacts to the transmitter. I am using it for a throttle on a petrol boat so speed is pretty key. The servo speed adjustment is maxed out on the Morph. I am using a planet T5 and the throttle servo is a "Tower Pro 996R"

Does anyone know how to rectify the Lag? I suspect the servo is a bit rubbish but would appreciate any advice.

Forgot to mention - the servo had no lag before adding the P96
Cheers
Title: Re: Action P96 Servo Morph Lag
Post by: derekwarner on April 27, 2016, 11:30:13 PM
me3................

I have three ACTion P96 servo morphs......have trialed each for set point & arc extent  :-)) and am using these set to provide each ~~180 degree travel and over ~~4 seconds end point to end point

These exhibit ZERO delay response in either direction from either end points or any part point angle of travel

The trials were conducted with JR  NES-537 bogstandard servos

May be worth trialling an alternate servo O0 ........... Derek
Title: Re: Action P96 Servo Morph Lag
Post by: inertia on April 27, 2016, 11:38:30 PM
P96 does not like 'digital' servos. In a nutshell, the microprocessors on which they rely are fighting the one on P96 for superiority in the chain of command. In fairness they were introduced after it was designed and I've not found one yet that will work properly with it. If you want to pursue the problem then I suggest you contact Component Shop direct. If you don't then Derek's suggestion seems eminently sensible.
DM
Title: Re: Action P96 Servo Morph Lag
Post by: me3 on April 28, 2016, 06:44:42 PM
Thanks for the advice chaps, I will try with another servo and I'll let you know how it goes.