Model Boat Mayhem

Please login or register.

Login with username, password and session length.
Pages: [1]   Go Down

Author Topic: HELP needed with Robbe Scheutze radio  (Read 1393 times)

DickyD

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 9,497
  • www.srcmbc.org.uk
  • Location: Southampton UK
    • SRCMBC
HELP needed with Robbe Scheutze radio
« on: April 21, 2007, 02:55:28 pm »

Problem
2 Robbe motors [not sure of size]
50amp Tornado Marine ESC.
6V 12ah lead acid battery.
Futaba 40AM tx rx 2 channel.
Runs fine to port.
Runs fine ahead.
Runs fine astern
Does not run fine to starboard. Motors intermitent and can hear rudder oscillating.
Has been fine up till now.
HELP.

Richard
Logged
Richard Solent Radio Controlled Model Boat Club http://www.srcmbc.org.uk

Shipmate60

  • Global Moderator
  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 5,480
  • You bark - I will bite!!!
  • Location: Fareham
Re: HELP needed with Robbe Scheutze radio
« Reply #1 on: April 21, 2007, 03:43:04 pm »

Richard,
How many chanels on your radio gear.
Try swopping the rudder servo connection with the throttle connection on the reciever.
If it still does it then there is a problem with the instalation, if the problem changes to throttle try another reciever.

Bob
Logged
Officially a GOG.

kendalboatsman

  • Guest
Re: HELP needed with Robbe Scheutze radio
« Reply #2 on: April 21, 2007, 04:07:51 pm »

Have you got any metal to metal contact when you turn to starboard that isn't there in a port turn? Something rubbing against something else? Steering rod etc.

Clive
Logged

J.beazley

  • Full Mayhemer
  • *****
  • Online Online
  • Posts: 902
  • The building never ends
  • Location: Locks Heath, Hampshire
Re: HELP needed with Robbe Scheutze radio
« Reply #3 on: April 21, 2007, 05:30:53 pm »

sounds like my radio problem is rubbing off onto your Schutze ::)

just a thought up the voltage to 7.2 and see if that makes a difference did wonders for me.

Jay
Logged
1:48th scale for my ships. Large enough to show gratuitous detail, small enough to stay married.

DickyD

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 9,497
  • www.srcmbc.org.uk
  • Location: Southampton UK
    • SRCMBC
Re: HELP needed with Robbe Scheutze radio
« Reply #4 on: April 21, 2007, 06:30:26 pm »

Have you got any metal to metal contact when you turn to starboard that isn't there in a port turn? Something rubbing against something else? Steering rod etc.

Clive
No metal to metal its all plastic linkage Clive.

Richard
Logged
Richard Solent Radio Controlled Model Boat Club http://www.srcmbc.org.uk

kendalboatsman

  • Guest
Re: HELP needed with Robbe Scheutze radio
« Reply #5 on: April 21, 2007, 08:19:59 pm »

Did you try replacing the steering servo in case it is a servo error causing feedback to the receiver.
Logged
Pages: [1]   Go Up