Model Boat Mayhem - Forum

Please login or register.

Login with username, password and session length.
Pages: [1]   Go Down

Author Topic: Action Electronics P102 Distribution board  (Read 1088 times)

olly4950

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 108
  • Location: Telford
Action Electronics P102 Distribution board
« on: July 07, 2016, 09:21:03 PM »

Hi to all.
I have a P102 Distribution board connected to a P94 ESC,my P94 is connected to TB2 and TB4.
The problem is that under NO LOAD the 15 amp fuse keeps blowing on the TB2 group, how ever if I take the fuse out opposite the TB4 this it has no effect the motors, they keep working.
I thought that each fuse controlled individual groups?
I have 2 of these boards and both operate the same.
Any advice?
Logged

inertia

  • Guest
Re: Action Electronics P102 Distribution board
« Reply #1 on: July 07, 2016, 11:42:21 PM »

The two fuses on P102 share the load because the split + and - are reconnected at the P94 board; it's all to do with the capacity of the cables to carry the maximum current. If you are using separate ESCs then your assumption is correct.
If one fuse keeps blowing then it's quite likely that one or both of the diodes on P94 has blown. These are the little black cylinders between the green screw terminals. If they are blown then you can usually see that the body is physically damaged and/or that the solder tracks underneath are burned. In that case it needs repairing, which is a ten minute job. The diodes are slightly less than one penny each.
DM
Logged
Pages: [1]   Go Up