Model Boat Mayhem

Please login or register.

Login with username, password and session length.
Pages: 1 [2]   Go Down

Author Topic: Lack Of Mojo on my Corvette & Enterprise  (Read 3099 times)

ojays

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 223
  • Location: Hull
Re: Lack Of Mojo on my Corvette & Enterprise
« Reply #25 on: January 09, 2019, 10:34:01 pm »

No, this is Stan's internal shots of his A.T.C.H.

The motor for the Huey is being powered by the same battery that is
driving everything else in mine.
« Last Edit: January 09, 2019, 10:55:01 pm by ojays »
Logged
Age is but a number!

ojays

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 223
  • Location: Hull
Re: Lack Of Mojo on my Corvette & Enterprise
« Reply #26 on: January 09, 2019, 10:51:38 pm »

I now have some serious thinking to do now that build is finished.
I have several builds on the go, 1/72 Gato, 1/72 Flower Class, 1/350
USS Enterprise and a 1/96 Type 22 that I recently acquired (unfinished)

I'll spend a few days going over them to see what grabs my mojo.
Logged
Age is but a number!

Stan

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 3,188
  • Location: West Yorks
Re: Lack Of Mojo on my Corvette & Enterprise
« Reply #27 on: January 09, 2019, 10:52:52 pm »

Hi Derek and ojays the 2 volt battery used to provide power for the main rotor via a speed controller. The radar motor and all LED lighting and small motor for the radar screen this is driven by a elastic band through geared unit from a water meter. The battery will be replaced by a voltage regulator feeding a Action two way switcher.


Stan


 
Logged

Steam Boat Willie

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 31
  • Model Boat Mayhem is Great!
Re: Lack Of Mojo on my Corvette & Enterprise
« Reply #28 on: January 10, 2019, 10:46:36 am »

A couple more of Stan's for reference.
Logged

ojays

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 223
  • Location: Hull
Re: Lack Of Mojo on my Corvette & Enterprise
« Reply #29 on: January 10, 2019, 10:48:55 am »

Brilliant, just brilliant.
So much going on there, thanks for posting.
Logged
Age is but a number!

ojays

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 223
  • Location: Hull
Re: Lack Of Mojo on my Corvette & Enterprise
« Reply #30 on: March 16, 2019, 10:32:16 pm »

Finally got her in the water.
Logged
Age is but a number!
Pages: 1 [2]   Go Up