Model Boat Mayhem - Forum

Please login or register.

Login with username, password and session length.
Pages: [1]   Go Down

Author Topic: Help please - "runaway" motors  (Read 448 times)

Peter57

  • Shipmate
  • *
  • Offline Offline
  • Posts: 22
  • Model Boat Mayhem is Great!
  • Location: Grantham UK
Help please - "runaway" motors
« on: September 26, 2019, 05:15:46 PM »

I own a beautifully built paddle steamer which I recently acquired second hand. When I first got the boat everything was working as expected.

Having not used the boat for 3 to 4 weeks I found two problems when I tried to connect the power supply:
1) The transmitter (Futaba F14 "Navy") and receiver appeared to be not communicating.
2) As soon as I switched on the power supply the motors ran at (probably) about 80% of full speed.

With the help of a member of my local club we traced the first problem to a failed BEC, which is taken from a power distribution board. Once this was bypassed we were able to get the transmitter and receiver working, e.g. rudder control was restored.

Unfortunately, the motor problem persisted. Moving the throttles to full did result in a slight increase in motor speed and reversing them abruptly reversed the motors. So some communication appeared to be present, but there was no neutral position or proportional throttle at lower power. Unfortunately, the ESCs are  amongst the least accessible electronic components, but I believe from the information I have they are Action Electronics P80s.

Does anyone have any thoughts or suggestions as to how I could further investigate and hopefully fix this problem?

Many thanks in advance.
Peter
Logged

john44

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 1,399
  • member of the Potteries Model boat club
Re: Help please - "runaway" motors
« Reply #1 on: September 26, 2019, 09:24:01 PM »

Hi Pete, sounds like a question for Mr DM.


John
Logged

DaveM

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 372
  • Why on earth do I do this?
  • Location: Nottingham
Re: Help please - "runaway" motors
« Reply #2 on: September 26, 2019, 11:24:44 PM »

My expert technical appraisal is that they need repairing..... If they are indeed P80s then it sounds like the MOSFEts have a dose of backwards electricity and walked off the plot. Are you able to remove the speed controllers and send them to me for checking over?
DM
Logged

Peter57

  • Shipmate
  • *
  • Offline Offline
  • Posts: 22
  • Model Boat Mayhem is Great!
  • Location: Grantham UK
Re: Help please - "runaway" motors
« Reply #3 on: September 27, 2019, 07:36:51 AM »

John and DM - many thanks for your comments and suggestions.

I will have a go at removing the ESCs. As I mentioned they are amongst the least accessible components, as they are buried under a power distribution board. It will be an interesting test of my (lack of) dexterity!

Regards
Peter
Logged

malcolmfrary

  • Full Mayhemer
  • *****
  • Offline Offline
  • Posts: 5,568
  • Location: Blackpool, Lancs, UK
Re: Help please - "runaway" motors
« Reply #4 on: September 27, 2019, 10:23:52 AM »

It should be normal practice for the distribution board to have been installed so that it would be removable.  If that was the deliberate mistake that the original builder put in, now is the best time to rectify it. 
Logged
"With the right tool, you can break anything" - Garfield
Pages: [1]   Go Up